tFilterRSTCommunity

TIMETRA-FILTER-MIB · .1.3.6.1.4.1.6527.3.1.2.21.12.1.4

Object

column obsolete r/w SNMPv2-TCDisplayString
The value of tFilterRSTCommunity is the SNMPv1 or SNMPv2c Community
String or the SNMPv3 Context Name used to conduct this SNMP test as
described in RFC2571 and RFC2737.
              
When the value of tFilterRSTSNMPVersion is 'snmpv1' or 'snmpv2c'
this object represents a community string.  When the value of
tFilterRSTSNMPVersion is 'snmpv3' this object represents a SNMPv3
context name.
The value of this object can only be changed if the object
tFilterRSTOID is changed at the same time.
              
This object is obsoleted in release 13.0.

Context

MIB
TIMETRA-FILTER-MIB
OID
.1.3.6.1.4.1.6527.3.1.2.21.12.1.4
Type
column
Access
readwrite
Status
obsolete
Default
""
Parent
tFilterRedirectSNMPTestEntry
Groups
2

Walk the column to discover its indexed instances, or supply every index to read one instance.

Walk the column
/usr/bin/snmpbulkwalk -v2c -c '<community>' -Pud -Ir -OQUs -m 'TIMETRA-FILTER-MIB' -M '/opt/observium/mibs/nokia:/opt/observium/mibs/rfc:/opt/observium/mibs/net-snmp' 'udp:<hostname>:161' 'TIMETRA-FILTER-MIB::tFilterRSTCommunity'
More examples
Read one indexed instance
/usr/bin/snmpget -v2c -c '<community>' -Pud -Ir -OQUv -m 'TIMETRA-FILTER-MIB' -M '/opt/observium/mibs/nokia:/opt/observium/mibs/rfc:/opt/observium/mibs/net-snmp' 'udp:<hostname>:161' 'TIMETRA-FILTER-MIB::tFilterRSTCommunity.<tFilterRedirectPolicy>.<tFilterRedirectDest>.<tFilterRedirectSNMPTest>'
Translate to a numeric OID
/usr/bin/snmptranslate -Pud -Ir -On -m 'TIMETRA-FILTER-MIB' -M '/opt/observium/mibs/nokia:/opt/observium/mibs/rfc:/opt/observium/mibs/net-snmp' 'TIMETRA-FILTER-MIB::tFilterRSTCommunity'

Syntax

Source
SNMPv2-TCDisplayString
Base type
OctetString
Display format
255a
Type Description
Represents textual information taken from the NVT ASCII
          
character set, as defined in pages 4, 10-11 of RFC 854.
          
To summarize RFC 854, the NVT ASCII repertoire specifies:
          
  - the use of character codes 0-127 (decimal)
          
  - the graphics characters (32-126) are interpreted as
    US ASCII
          
  - NUL, LF, CR, BEL, BS, HT, VT and FF have the special
    meanings specified in RFC 854
          
  - the other 25 codes have no standard interpretation
          
  - the sequence 'CR LF' means newline
          
  - the sequence 'CR NUL' means carriage-return
          
  - an 'LF' not preceded by a 'CR' means moving to the
    same column on the next line.
          
  - the sequence 'CR x' for any x other than LF or NUL is
    illegal.  (Note that this also means that a string may
    end with either 'CR LF' or 'CR NUL', but not with CR.)
          
Any object defined using this syntax may not exceed 255
characters in length.

Values & Constraints

Object Constraints
range: 0-32
Type Constraints
range: 0..255